I’d like to suggest a change to this one. It says:
" Add three more parameters called red
, green
, and blue
to your function definition for drawFish
which allow you to set the color of the fish when you call the function. Remember to separate them with commas!"
Given that we’ve already learned that “red”, “green” and “blue” are presets for actual colors, naming the parameters red, green and blue is confusing to students (and bad coding practice). To make it clearer that these parameters represent RGB values, maybe this could say:
" Add three more parameters called rval
, gval
, and bval
to your function definition for drawFish
which allow you to set the color of the fish when you call the function. Remember to separate them with commas!"
Thanks! JR