How do I switch my page to English

I noticed that the home page is in spanish by default and I have to force translation on it. Even after translation some of the pages seem to continue to have spanish text. This is not a browser problem as I don’t have this issue with any other website I visit.

Here is the page with mixed english and spanish

Did you set your language settings to Spanish when you signed up? You may want to contact to have them take a look at this.

There’s a dropdown at the bottom of the page to set your language.

I found the dropdown. But English is not an option there. Is there a way to reset and default to English?

I guess it corrected itself. And now there is English as an option on the bottom language dropdown. Thanks for your responses.

1 Like