Serial Port Connection Error with Circuit Playground on Chromebooks

I’m getting a weird error this morning that I’ve never seen before while using the Circuit Playground Express on my teacher Chromebook and all of my student Chromebooks when trying to connect our boards and run programs. The Maker Toolkit IT Setup page is giving the same exact error. There’s a screenshot below of the error message we’re getting. Is this a problem everyone is seeing today? Everything has been working all week, until this morning. The connect button is grayed out and can’t be clicked. I’ve tried several solutions with no success.

I’ve managed to solve my own problem! Thank goodness!

If anyone has this issue in the future, all you and your students need to do is click on the text where it says “Circuit Playground Express (ttyACM0)” and then the ‘Connect’ button will turn blue, and you can click on the button. After that, the pop up will go away, and you’ll be able to connect the board and run the programs. This is the solution for teacher and student chromebooks for this particular issue. Not sure why this is popping up all of a sudden, but glad there is an easy solution!

Hi @david.decker,

So glad you solved the problem. Your solution helped me as well. I tried to recreate your problem with one of my boards. My board needed firmware first because Chrome wouldn’t see my board. I used the tips from #2 solution under “Debugging Common Issues” on this page. After I installed the firmware and plugged my board in, the message was exactly the same as your screenshot. I followed your instructions and my board was up and running!!

Thanks for the tips!!

:wave: Hi folks - just wanted to chime in and say: sorry for any unexpected disruption this caused, and we’ve added a new section to our support article at the very bottom that might help clarify this issue if it comes up again.

Have fun with the Circuit Playgrounds!
Dan - Curriculum Writer