Trouble connecting CP

I handed out the Circuit Playground boards and before I could see the students again, then the next day our school switched over to online instruction for Covid-19. It happened very suddenly.

One of my students and I are having trouble connecting CP to MakeApp. She is on a PC, I’m on Mac.
She has the Express, I have Classic. I have read all the forum posts here and still not sure how to troubleshoot.

I tried downloading the firmata for CP Classic, but could not load it using the Arduino IDE because of an error that says I have no WebUSB. I posted about this to the Arduino board.

Before I get the student to try and do the firmata, I thought I’d check in here.

People are very stressed right now, students included. I’m starting to feel like maybe with all the extra screen time that’s ramping for remote learning with Covid-19, I should drop Unit 6 (which I was really looking forward to) and get my class to do something totally different as a remedy.

When I am in Maker Toolkit standalone app, the support docs say I should be able to “make sure all the steps are lighting up as green / your board is showing up as connectable.”

I am not able to see anything happen when I click on the setup icon in the menu from the Maker Toolkit app:

It simply refreshes the page and directs me back to the page called “CS Discoveries Maker Toolkit IT Setup.”

Hi @fhtoosi,

I love that you were able to hand out circuit boards. Although Unit 6 counts as screen time, I love the maker/hands on theme of the unit. Think of all the creative things they could invent with supplies from around the house! But you are correct, it does come with its set of difficulties connecting the boards.

I’m assuming the student has installed Maker App. That is the number one error I have with students connecting. And even though students install Maker App, they forget to use it and try to connect through a browser. So, I would just double check the student is actually using Maker App. Here is the instruction page for Maker App just for reference.

Assuming they are using Maker App and you need to install the firmata, here is my go to super easy to follow page for installing the firmata. on the Circuit Playground Express.

Good luck connecting your classic.

I hope these ideas help. Keep us updated on your progress!
Michelle

Thanks @melynn. I can confirm that we are in the Maker App, not the browser. Heard same from another student.

Do you know if the Windows driver is usually needed as well (it’s described in the page before the firmata install)?

I added a WebUSB library to my own device using the Arduino IDE, and was then able to add the firmata and I can get confirmation that the computer and browswer recognize the CP. But I’ve still got no connection to Maker App.

I recreated the problem on my Windows 10 machine. I installed windows drivers and the firmata and restarted. Maker App did not see the board although my computer did see the board. I went to code.studio in Chrome (lesson 3 activity 4) just as one further troubleshooting attempt and Chrome sees my board. Perhaps the same is true for you? Can you (or your students) try the boards in Chrome? If this step doesn’t work, it would be best to reach out to http://support.code.org/ for support.

Michelle