Unit 5 Lesson 2 Level 1 Error?


When resetting this level, the heading text is located in the middle of the screen, and the top image is missing.
What might be the problem?

Link to module: https://studio.code.org/s/csp5-2022/lessons/2/levels/1

Please share the link to the project so someone can look at it.

Link added to original post.

I’d like the link to the code that you want us to help with. Click on the Share button and copy/paste the link here.

https://studio.code.org/projects/applab/yC32qKlmmguyluR9jpd9GYxtjbKY7GN4EoMnkWm7KFk

This is the initial version for my students: The topImage is missing, and the appName label is wrongly placed. Running the app completely misplaces the appName label, and no show of the topImage.

I would expect, that the initial version of the app in unit 5, lesson 2, level 1 is a working app.

I have noticed that the Version from 27.11.2022 11.16.01 is correct. So, if I restore this version, the app is working. I do not know if my students have the option of returning to Version from 27.11.2022 11.16.01. I will investigate next Friday.

When you say resetting this level do you mean when they use version history and choose start over? Is it something else?

Yes, I mean using version history and choosing start over. I did not have the English terms as I use a Danish version.

I tried it and it works as expected for me. I did not remix it, just stay in the unit and lesson.

Let us know if there is a change on Friday.

When I press the above link, I get the following picture:


Notice: appName label is located in wrong place.

If I then press Show Code I get the following picture:

If I then press Design, I get the following picture:

Notice: the appName label has moved to the far left as a small square.
In all cases the topImage is missing: in design window, and design item list:
image

Running the app gives no errors, even though the topImage is referenced:
image

Notice: This is after using version history and choosing start over. Which I would expect should return to a stable state.

I wonder if this still happens with. You look at it from a different browser or computer. If not, it could help narrow down where and when the issue occurs.

It may be worth a support ticket. If there is an error in the level or it is rendering in an unusual way for some folks we’d love to get it cleared up. Would you please email support@code.org with the details in your previous post as well as information about what type of computer and browser you’ve tried?

I have tried my best, to describe and test on various platforms (few), and sent to support at code.org.

I have now tried to find a workaround with the students. Using version history start over could not bring a error free version to the affected students. Instead I shared my version with them. Thus they needed to work outside the CS Principles environment.

Further more other levels were affected as well.

All reported to support.

Sorry to hear about this issue! I believe I’ve isolated the problem and learned that it’s only happening when the site is not being used in English. You’ve helped us uncover a translation bug in App Lab!
I imagine you’ve already moved past this lesson. If it happens again, you can try switching the site back to English before resetting version history. If the project looks good after that, it should be okay to switch back to Danish.