Circuit Playground Issues

We are currently working in Unit 6: Physical Computing in the CSD curriculum. We are on Lesson 6 at the moment. I have about 12 Adafruit Circuit Playground Classics and 12 Adafruit Circuit Playground Express boards. They have been working fine for two years and worked fine until we got to lesson 6. Today not one student could get their board to connect. We tried in the Maker App and also using Chrome with the Serial Connector for installed. Both of these have worked fine in the past.

Myself and my students are beyond frustrated. Adafruit doesn’t provide any assistance via email or over the phone. They only provide the forum which hasn’t been helpful. Any advice or guidance would be appreciated.

Are you running the setup check inside the Maker App? If so, is it giving you green indicators on all parts or does it stop somewhere?

You may want to reach out directly to rather than to adafruit as they are usually pretty responsive and best know how the circuit playground integrates with the Maker APp.

It could be a network issue at your school, but they could help you out, I’m sure.


Hi @kposten,

Since none of your boards can connect, I am wondering if this has to do with recent updates made to the Maker App and the procedure for logging in. The new updates are outlined here and does require the most up-to-date version of Maker App.

The only other issue I have run into with our boards not connecting occurs when we go back and forth from MakeCode to It requires us to reinstall the Firmata for The instructions on the page are pretty easy to follow.

Hope this helps!