So frustrated with Circuit Playground


#1

I have tried everything…maker toolkit, adafruit drivers, arduinoCreateAgent, Arduino 1.8, Circuit Playground Firmata Master and no matter what I try I cannot get these to connect. They said this would be easy…


#2

With the board plugged in, can you open up the Maker App (at https://studio.code.org/maker/setup if you don’t already have it) and click the gear icon? This should take you to a diagnostic page which should give you more information to help us debug.


#3

Setup Checkre-detect
Code.org Browser
Adafruit drivers installed
We can’t actually check this, but you should double-check that you have the Adafruit Windows Driver installed.
Board plugged in
Board connectable
We found a board but it didn’t respond properly when we tried to connect to it.
You should make sure it has the right firmware sketch installed. You can install the Circuit Playground Firmata sketch with these instructions.
Still having trouble? Please submit our quick survey about your setup issues.
Board components usable


#4

I have installed Firmata at least 4 times, I have reset with the reset button at least 4 times…none of this is working!!! I am just about ready to give up teaching this lesson, I had to buy the boards out of my own pocket and nothing is working


#5

Can you confirm for me that you’re using the Circuit Playground Classic on and not the Express? The Classic should come with the firmata pre-installed. I’d also like you to submit the setup survey which will send some additional debug data to our engineers. Sorry that this is causing some much trouble for you.


#6

@cshock just wanted to check and see if you’ve had any success. If you’re still unable to get your board connected I can connect you with one of our engineers to continue debugging.


#7

Well…we found out there are 3 kinds of boards…classic, developer, and express…express only works with Makecode, classic only works with code.org and developer works with nothing…


#8

There’s actually only two distinct boards, the Classic and Express (both of which were initially released as developer editions). The Express was initially not supported by the Maker Toolkit, but Adafruit recently added support (details at https://learn.adafruit.com/adafruit-circuit-playground-express/code-org-csd). The developer edition of either should work fine - can you identify for me whether you’re using the Classic of the Express using this page https://learn.adafruit.com/adafruit-circuit-playground-express/classic-vs-express


#9

I’m having the same problem getting my boards to work - I’ve tried multiple boards and all the suggestions below but still no success.


#10

Flip your board over. Does it say Classic, Developer or Express.

  1. If it says classic go here
    https://studio.code.org/maker/setup

  2. If it says “Express” you can only use MakeCode (you cannot load the “Firmata” code onto the Express boards
    makecode.adafruit.com

  3. If it says “Developer” I don’t know what to tell you as I have one “Developer” board and it does not seem to work with anything


#11

Does your board say either ATmega32U4 or ATSAMD21 on it somewhere? If the processor is an ATmega32U4 then you should be able to install the Classic firmata on it, and if it’s an ATSAMD21 you should be able install the Express firmata as described here https://learn.adafruit.com/adafruit-circuit-playground-express/code-org-csd


#12

Mine says “classic” on the bottom


#13

It says ATmega3204 . Everything looks good when I go through the setup check, but then it doesn’t detect it in code studio (lesson 3, level 4)


#14

Interesting. What platform (Mac/Windows/Linux/Chromebook) are you on, and are you using the Maker App or the browser extension?


#15

Windows 10. I’m using the Maker app.


#16

And just so I’m clear, when you visit the setup page by clicking on the gear, all of the steps turn green, the board LEDs turn on, and it plays a song, but when you visit a curriculum level it doesn’t work. Do you get an error when trying to access one of the curriculum levels, or does it just spin at the connecting screen forever?


#17

I think I figured it out - it only works with the app. I was trying to get it to work going to code studio with a browser. This should probably be made more clear for future users.


#18

Sorry to say, but I’m having similar problems as cshock. On the setup check, it gives me a green check for “code.org browser” and “board plugged in” and then I get a red x for “board connectable.” I’ve installed the firmata, the IDE, tried to connect both together and still nothing. I’m getting frustrated with it. I submitted the Google Form for more assistance and haven’t heard anything yet. I’m hoping to start this unit with my students within the next week. Thanks!


#19

Hello everyone! I’m sorry to hear that Circuit Playground setup is giving you trouble. If the steps @josh described haven’t worked for you, will you email support@code.org for further assistance? We may be able to help better on a case-by-case basis. Thanks!


#20

Just wanted to give a quick update… I did figure out how to setup the boards! I think I was having a problem setting up the Arduino IDE with the board and the port and then pushing the firmata out to the device. Anyhow, my CS classes have been in the unit for about a week now and we are loving it!! This is probably my favorite unit from the year! Great job with the materials and curriculum!! Sorry I had a rough start. :slight_smile: