Drawing the Shapes


#1

I’m not sure what I’m doing wrong, but how do you get the drawing tools to show up. I have tried it on two different systems, with two different browsers. I have tried. Chromebook and Mac.


#2

Hi Morgan,

You’re not doing anything wrong. A couple days ago, a bug was introduced that deleted the code from several of our levels. We thought that we had caught and fixed them all, but because of the way these “hidden code” levels work, we did not see that there was still missing code in them. I don’t have the code for this one, but I’ll get in touch with the person who does and we’ll try to get it back up by tomorrow morning. I’ll post here when we have an update on the situation.

Elizabeth


#3

@mdaniels

We are working on a fix, but in the meantime, you can use this Game Lab project:

Is is the same program as the one in the level, but the underlying code is visible.

Elizabeth


#4

Hi, this should be working now. Thanks for your patience, everyone.

Elizabeth


#5

I’m doing this lesson in a week and when I previewed it it does not show the drawing tools. Of course, I didn’t think about coming here first to look to see if it was a problem until after much time thinking I was too stupid to remember how to do it :slight_smile: . I see the alternative lesson you mentioned but I wanted to let you know the tool bar is not working again. It was working 3 months ago when I went to training. I also tried on 2 different computers and browsers and nothing happened. Any help would be appreciated. Elaine


#6

Hi Elizabeth,
I just sent a post about the drawing toolbar not working again for Unit 3 Lesson 2.
I saw this link https://studio.code.org/projects/gamelab/9uJoU6NkxcEhrxI2uN2aGiFhOCTQHA5W3V_zJEkd2zM
that you posted in a previous post, but it does not seem to have the grid option on it, unless I’m doing something wrong. Does it have a grid option or is it just for students to understand the drawing tool?
Thanks, Elaine


#7

Hi Elaine,

The eve appears to be working for me. Can you try one more time?

Please note that every time you want to draw a shape, you have to click the shape button again. This is analogous to having to use the shape command every time you want to draw a shape with code. So, for example, I would click the blue button, then click the square, then I could stamp one square on the canvas. If I wanted to draw a second square, I would need to click the square button again.

The version that you have in the link does not have a grid because it is in display mode. If you choose “How it works” from the “Built on Code Studio” menu, you should be able to click the grid on and off.

Elizabeth