Hi - instead of creating variables with a default label of “x”, could they be
var label or var variableName or something that gets away from the “mathy” x? I think it would help my students see that they need to give a descriptive name to the variables they create. It would also keep some confusion away from students who are mixing up the x,y for coordinates with the x for the default variable name.
Similarly, when creating a sprite variable, could the default be spriteLabel ? I think this would to also help students see that they are creating a new sprite that should have a unique label.