Unit 8 (AI) Lesson 1 Stage 9 Drop down menus don’t work on apple ipads

HTTPS://studio.code.org/projects/app lab/Bwp6d_lkZOZHQmXIFxhAWsDUe6r5NDQhs61xmf6U6Yk?sms=true

I expect the drop-down menus to work. They do not work at all on my student’s apple i-pads (no mouse clicks - is this the issue?). They work with a mouse on my Acer laptop except when it comes to choosing the image when it only gives me the option to “upload a file”. I want the pre-loaded images from code-org; I don’t want my students surfing the web for images.

Concerning the apple i-pads we were able to just type in the text we wanted when the drop downs didn’t work until we got to this level. Sometimes we can see the options in the drop downs but not select them. For the “choose” items we can’t even see the options because we can’t click on “choose”.

Link to the project or level: [replace with link to the curriculum or get the “Share” link to a project]
What I expect to happen: [replace with a detailed description of the behavior you’re trying to create]
What actually happens: [replace with a detailed description of what actually happens when the code runs including any errors or unexpected behavior]
What I’ve tried: [replace with a detailed description of what you’ve already tried to do to solve the problem]

PS This is probably a better link. Also I did try to switch out of block mode but applab doesn’t seem to want to except my apple iPad quote marks. Concerning choosing an animal image it seems they intended to make a library available but it’s not there?

Hi @lisa.sinanan,

I know it is frustrating when lessons don’t work as you hoped they would. iPads can be tricky. A good place to start is to make sure you meet the minimum requirements when using iPads. The IT Requirements document states that, “Compatibility with iPad requires the- iPad to be running iPadOS 13.4 or later with an external keyboard and an external mouse or touchpad”. If you are not meeting the minimum requirements, it could explain the issues. I was able to test the lesson on an iPad with an external keyboard and touchpad. I used an updated Chrome browser on the iPad and I was using iPadOS version 17. The lesson did work and I was able to toggle back and forth between block/text mode. I could also type quotes. It wasn’t perfect as sometimes the blocks would hide but returned if I hit reset run or toggled block/text mode again.

In regards to the images, Code.org does not have a library of jpg images for App Lab. The images already loaded in the app on that activity were there as examples. Your students can either type in a URL for an image from the web OR upload images OR students can go to the icon tab and choose an icon which are single color emojis of sorts. So, if you don’t wish students to search the web, you can have some images available for them to link to or to upload (or use the simpler icons). I have done this before via Google Drive when I wanted a bit more control over student image choices.

If you are meeting the minimum requirements for the iPad and continue to run into issues, you can contact support and they will be able to help you further troubleshoot the lesson.

Good luck!

1 Like

Thank you! I was beginning to suspect the browser might be part of the issue as we use Safari, not Chrome. We’re on iPad0S 17.3 so we’re OK there. But you are right that we also do not have a touchpad or mouse; I’ll have to see what we can source. We’ve been able to do a lot without these but it certainly explains a few of our issues. Thanks again!