AppLab program doesn't run - Unit 3, Lesson 5

My students are going thru the Unit 3 Lesson 5. I have a student that is having problems with AppLab. She would drag and drop commands (like moveForward) and click Run, but nothing happens and the turtle doesn’t move. The only way I figured out how to fix it is to add another command at the very beginning, show the code as text, comment it out, then Run it (now it works!), then delete the commented command and now the turtle runs (no other code changes were made). This “fix” worked until Bubbles 9 & 10. The student is now reporting that the “fix” is not working.

Any help would be greatly appreciated.


Hi @eugene_schwartzman,

Would it be possible to use the “Share” feature to post a link to an example of one that doesn’t work?

Meanwhile, another thing I would try is report the issue to I would include the student’s unique username (not their display name, which might not be unique) so the engineers can look into that account. I suspect they might want you to capture any error codes that may appear. (Right-click, select “Inspect”, click the “Console” tab, and check for any red error message that appear when you run the app.)