Links Not Working in WebLab

[Posts in the debugging category need to have the following pieces of information included in order to help other teachers or our moderator team best help you. Feel free to delete everything in brackets before posting your request for debugging help.]

Link to the project or level:

What I expect to happen:
The links on the NAV bar at the top of kill.html should work in WebLab.

What actually happens:
When in WebLab (i.e. when you click on “View Code” at the bottom so you can see the code and the web page side-by-side), clicking these links takes me to a blank page.

Clicking on the same links on the other pages (e.g. index.html) works fine.

Strangely, the same nav bar links on the kill.html page work fine when viewing the page in full screen mode.

What I’ve tried:
I tried removing the class=“bar”, but that did not help.
I tried using Firefox instead of Chrome, but that did not help.


When I try it, it seems to work just fine. Maybe try a different browser and see if it may be something else relating to that computer. Just a thought.

Let us know!



Thanks for taking a look!

I tried chrome and Firefox.
You tried the links at the top of the kill.html page in web lab when the screen is spilt between coffee on the left and the page on the right? That’s where we see the problem. When viewing full screen, it works fine.


John Wilson

Computer Science & Math Teacher

Park Slope Collegiate


OK. I took another look. I believe I have found the error.

Technically, all href links (links to pages and links to sites) should be surrounded by quotation marks. Most of them are working without the quotation marks, but they should have them.

I started adding them on the killbill page and when I got to line 29, the site was fixed. I then undid all the changes and it was broken again. This time, I just fixed line 29 (see screenshot below), the page started functioning properly again, so making that fix should fix the issue, but all links should be surrounded by " ".




I was CERTAIN that you had found the problem and a bit embarrassed I had not noticed that myself. Another set of eyes is always helpful!

However, my student made the changes and the problem persists! :thinking:
The problem exhibits itself on at least one other student’s workspace (this being a team project).

So now I am just confused.


Here’s the one I fixed. I’m pretty sure the only thing I changed was line 29. See if it works on your machine and if so, maybe compare the two?