Maker App showing 'Rotate device' screen on laptop

Whenever one of my students tries to run projects or lesson levels with the maker toolkit enabled in the Maker App, she gets the “Rotate your device. Turn off orientation lock in device settings.” screen and the program won’t run.

She is using a MacBook and the latest version of the Maker App (we tried uninstalling and reinstalling). I can open the projects without an issue from my teacher dashboard (also on a MacBook), so my instinct is that it’s something with her computer, but I’m wondering if anyone else has run into this.

It seems like it’s checking for a certain orientation and when it doesn’t see it (null, undefined, or the incorrect value) it’s showing the ‘rotate device’ message. This most likely can not be fixed user side, so you will have to pass it on to the developers of the app.

Yes, I may have her try logging into a different computer with her account and that would tell you if it was something to do with her account or the computer. If it’s her account, contact support@code.org and they can help you. You may also try a different board and see if for some reason that board is being wonky, but looks like you may have already tried that.

Let us know if you find a solution!

Mike

Yes, we’ve tried other boards, and gotten the same issue - it also affects old projects that don’t use the circuit board. I will have her try logging in on another laptop today, and pass the issue on to support if it continues there. I’ll also have a look at her system preferences - I wondered if maybe the Maker App was being detected as a mobile browser for some reason.

Thanks for the advice!

It seems to be a combination of computer and account - when she logged in on a different one, she could open the projects/levels just fine, and interestingly, she was able to open other people’s AppLab projects from the public projects on her computer without issue.

I also poked around the developer tools a bit - this was the console when she tried to open one of her projects, not sure if the content decoding error could be the culprit (I don’t get it opening her project on my computer), but that might be beyond the scope of the forum here.

the key target ‘densitydpi’ is not supported

this could be the culprit, the DPI on phones is usually smaller on phones, and this could be what it uses to check if it’s a mobile device. Because it’s not supported, it automatically assumes it’s on mobile.

I’ll see if I can get another set of eyeballs on this one, but you may also want to contact support@code.org if you continue to see issues.

Mike

I did think about that, but I get the warning on projects that I can open without issue, while the error does not show up on projects I can open. I will see what the support team says!

I got in touch with the Support team, and they asked what the student’s screen resolution was. She’s using the ‘Default for display’ resolution (‘Looks like 1280x800’). We tried each of the four ‘Scaled’ options (in screenshot below), with no change.

We have also discovered that, although she can open and run AppLab projects from the ‘public projects’ section, as soon as she clicks ‘How it works (view code)’ in the ‘Built on Code Studio’ menu, she gets the ‘Rotate Device’ screen again.

We decided to try sending the first project of hers that demonstrated this issue to our phones to see if that made any difference. The app opened normally, and clicking ‘How it works (view code)’ gave the ‘rotate device’ screen. Rotating the phone to landscape mode does get rid of it and let us see AppLab normally.

If she creates a new AppLab project in the browser, it’s fine, but she then can’t open that new project in the Maker App without seeing the ‘rotate device’ screen. So possibly it’s something on her account side? Is there a default orientation setting she could have hit somewhere? I’m not sure that would affect her ability to open other projects, though.

I replied to the support team with this (minus the last paragraph above, because I just thought of trying it), but I’m copying it over here as well just in case anyone else has thoughts/someone else runs into this in future.

Hi @ltoal,

This is definitely something that I’ve never encountered before. I’m glad you’ve been able to connect with the folks at the help desk, because this sounds like an issue that we’ll be unable to resolve through the forum. I’d love for someone to prove me wrong, though!

–Michael K.

@mkmietowicz Yeah, it seems like a really specific combination of events! I am just trying to be very XKCD 979 about it :wink:

2 Likes