Share links for weblab not working?

Hi, I am trying to setup a showcase for the staff & parents of my students webpages they created. When the students click the “share” button on their webpage it brings up a link, when we copy it and paste it in another browser the link does not work. I get an error “cant reach this page”. I have with other students web pages and get the same error. When they do it with their gamelab projects those work.

Here is an example from one of the web pages.

I would appreciate any help so I can get this worked out before our showcase.




When I click on the link you have shared it is working for me (showing me a website about Mexico). If you still can’t get it to work on your computers, you may want to try deleting the cache in that browser or if you have a computer with two browsers, maybe try a different browser to see if it is a browser issue.

If not, you can try to reach out to with information on the accounts in question and they can perhaps check for issues.

Let us know if you figure something out!


Hi, thank you for the reply! That is very interesting, That is what it should be, but when I try to open in chrome & explorer, this is what I get

If you’re trying this at school, you may be running into a content filter installed by your school or district … I know that may seem strange if some are working and some aren’t, but in my district, they use iBoss and I do see that behavior sometimes where different computers are hitting different filter servers.

Here is a page showing the sites that need to be unblocked. You may need to forward it to your tech people. In my district, they are usually responsive to this, although not always quickly. I know this can be frustrating, but this COULD possibly be the issue.


Hello, thanks for the reply again! I am using my personal computer, on my home wifi which I should have more freedom on. I came to the school building today and tried it on the school CPU and it worked, so I am happy that it does work, but I still cant figure out why I cannot see the web pages on my own laptop, I can see the links from the gamelab.

Thanks for your help!


1 Like

You may want to try an incognito window on chrome and see if that works. If, so it’s probably a browser cache issue.


Hi, I tried the incognito window and it still gave me the same message.

Hi @neville.e.voglezonjr , please contact us at and we can assist with this!

There was recently an update with the way the websites are published with Many school filters are blocking it since the change over. I would share the link with your district tech department and ask for it to be whitelisted. The good news is it probably has nothing to do with what the students created. It should just be a whitelist issue.

Hi, thanks for the response, funny thing is when I am at school on the school wifi with my laptop and the school computer, it actually shows on the school CPU, not my laptop. So it seems like something with my laptop setting does not agree with it, but the gamelab links work on my laptop. It is very strange.