Unit 2 Lesson 6 not working as expected

Trying to get an IP from the DNS using get name and sending to 1.15, but it’s not working. I’m trying this myself but I keep getting:

Automatic DNS Node
Usage: GET hostname [hostname [hostname …]]

Don’t remember having issues with this previous years.

Hi @dhust,

I tried it myself and the same thing was happening to me - got it working now though - looks like it’s case sensitive (possibly to emphasize that we’re using unique ASCII characters, where lowercase characters are differentiated from upper case). Try “GET” instead of “get”.

Good call. I was panic reading.

I am feeling really dumb here. What do you put in the [ ] after GET? I keep getting the same error you did. Thanks in advance!

Hi @nread,

You probably have the right idea, just do it without the [ ] - those just indicate it’s a placeholder.

So if there’s a user (host) named franklee3 and you want their IP, then you would type the DNS’ IP address into the blue “To” box, then in the message, type
GET franklee3
and you should receive a message containing user franklee3’s IP address.

Figured it out. Working too late I think. Thanks for the fast reply! -Nancy