Earth Science Challenge #1


#21

I chose the second challenge as I already coded for a second pump. I added a “Factory” area in black. When the already pumped water precipitates back to the ground and lands on the factory it’s polluted and infiltrates the ground. The pollution is tracked with a data box. I had a graph on there but it kept causing glitches.

My link is: http://www.slnova.org/eriedmayer/projects/161198/

I didn’t struggle too much. I was actually working on this while my students were participating in Hour of Code today so they were coding and I was coding. They were really impressed with my abilities. Ha - that’s probably a first.


#22

Emily- that is such a GREAT idea to be coding your own project while the students are engaged in the Hour of Code activities! That’s a double-win in my book. Paige


#23
  1. I chose the medium challenge because I wanted to create some original code instead of just copy and paste code.
  2. http://www.slnova.org/kenneth2.williams/projects/164077/
  3. I struggled with trying to get the pumps to look alike. One pump is wider than the other, eventhough they have the same size. Also, I struggled with creating the polluted area. I am on sure why the polluted area has an oval shape instead of a rectangular shape.
  4. How to change the terrain color and the purpose of the stamp grid command.

#24
  1. I chose the first challenge because I did not do this Module yet.
  2. http://www.slnova.org/bmueller/projects/180498/
  3. I struggled because I had to do the entire module on my own. I did Module 1 and 3 at the summer PD and then reviewed Module 3 and Module 4 at the fall PD. Module 2 is the only one I haven’t tried yet. Also, I am not sure I was able to access the actual Starter Model for this Module.
  4. I really just need to work through this entire Module another time to really understand it.

#25

Hi, I added a 3rd pump and plants. http://www.slnova.org/krisbeck/projects/81942/
I’m struggling with Star Logo Nova. I have to keep refreshing, quitting and reloading. I’ve tried working on multiple machines, PC, MAC, but I have the same problem with the shockwave flash. It is buggy.
My lastest project kept crashing.

Have a great holiday all!


#26
  1. I chose to do the simple challenge, add a third pump. It’s been a while since I worked on this and I didn’t feel up to the second or third challenge at the moment.
  2. http://www.slnova.org/cristine_maisano/projects/181003/
  3. This wasn’t a struggle at all to make - however, I am having some challenges in remembering the background behind this model - I may play around some more with trying to create polluted water after looking at a few other people’s models.
  4. No additional assistance needed at the moment.

#27

http://www.slnova.org/eagustin/projects/191617/

I’ve chosen the simple one. I was thinking how a student would react to a challenge based on ‘easy’ medium’ and ‘hard’ mode. Since I haven’t done any programming since I finished with my class last October I chose what I think students will do … ‘easy’ mode. It was easier than I thought since it was just a matter of copy and past and follow the tip on the location of ‘x’. … I didn’t think I would need help since it’s pretty straightforward. … I think it’s still best to ease a student in so not to overwhelm the student.


#28
  1. I decided to complete the “easy” challenge due to the fact that I haven’t had much success in this course.
  2. http://www.slnova.org/MrsPiper213/projects/181058/
  3. I have been able to create the third pump (yea me!) but the data box is not recording data.
  4. I don’t know where my coding is wrong and why the data box doesn’t record.

#29

http://www.slnova.org/kndoyle/projects/196561/

I decide to to the easy challenge because since I am not very confident in my coding skills. I was able to make 0nly 2 pumps but it took me a long time. I did copy the orginial model but for some reason the 2nd pump would not appear. I was able to look at other models to find my mistakes.


#30

http://www.slnova.org/masantana/projects/196756/

I decided to try to add a toxin that might pollute a specific area. My model includes the addition of a toxin and how this toxin “pollute” a water source. This model can be modified to alter the collision interval to illustrate how the addition of more water - can dilute a “lower level” of toxins.


#31

http://www.slnova.org/hahnhawk89/projects/198356/

I added a third pump because this is the module I have not completed yet. I struggled with pasting the code because it broke apart due to lack of room in the coding space. This caused me to edit my own coding since I ended up with some empty sockets.


#32
  1. I, like most others, chose the easy challenge. I don’t have 2 free hours to play with.
  2. http://www.slnova.org/jljohnson19/projects/199198/
  3. I used procedure parameters to choose the color and location of each water pump. I wanted those parameters to be added to a list and then have the “Groundwater Movement” procedure check against those colors. I searched for an hour trying to learn how lists work in SLNova and couldn’t figure it out. So I gave up.
  4. See #3.

#33

I did something a little different, creating different substrates that the water moves through at different rates. You choose which substrate you want the simulation to be set-up in (pebbles or soil). A slider bar changes the amount of water in the set-up. The simulation has three pumps, each has a different depth.
http://www.slnova.org/jhettinger/projects/202127/


#34
  1. I created the second pump with plant.
  2. http://www.slnova.org/weenna/projects/81998/
  3. The struggle was creating the plants.
  4. No help! Thank you

#35

http://www.slnova.org/cdhoff/projects/202469/

Evaporation of water in ecosystems is so important so I wanted to look at that.
Sometimes when I changed things, everything shut down…it was frustrating at times.


#36

Okay so here is my medium difficulty assignment. I think I’m rusty with the coding now that I’m in the midst of school. However, I created a “factory” (a black space) and whenever the water returns to the ground but lands on the black it stays stuck to the black. Can’t get it to change to black and then move down. Anyways…here it is…http://www.slnova.org/eriedmayer/projects/161198/


#37

I choose the add plants challenge because I thought it would be fun to create a variation in the cycle.

http://www.slnova.org/SBChorba/projects/202477/


#38

I chose the first challenge. I did not have much trouble with it

http://www.slnova.org/dpfest/projects/204591/


#39
  1. I chose the first challenge because I am not teaching this module.
  2. http://www.slnova.org/abreus/projects/207406/
  3. Reading the original code, as this is not a module we covered in my workshops.
  4. Took some time, but I figured things out.

#40

http://www.slnova.org/garys/projects/74406/

I chose question number one because it was the easiest and I have been struggling with coding. I struggled with copying and pasting the code. I couldn’t figure out why it wasn’t working, so I just added another pump. I had already created 3 pumps last summer, so I was creating four, but it didn’t come up when I ran code. I’m not sure what I’m doing wrong.