Has anyone got the Copilot lessons to work in Visual Studio Code?

After getting my CSA students all signed up and approved for GitHub Education, fighting to have our district install a JDK, and side-stepping around SSL certificate issues to install a local repository, we are stuck trying to compile the code in Unit 10 - Software Engineering, Lesson 3: Intro to Copilot. Specifically I am trying to compile the Urban Explorer code, and getting all kinds of messages relating to not finding javafx.scene. Any suggestions?

1 Like

Greetings,

Thanks so much for writing in about your experience. Iā€™m wondering if you might be able to provide some screenshots of the error in question. Also curious if you have had issues with any other apps as well?

Hoping to get this debugged for you pronto!
Erik

1 Like

Thanks for your reply, Erik. I was able to plow through and get it to work. I have class in 30 minutes, but I intend on following up with what the issues were and how I fixed them. The short answer is that in this lesson, which is supposed to show you the benefits of the AI tool Copilot, I ended up using Copilot to help me fix the problems. I guess I just demonstrated how great a tool Copilot is.

1 Like

Glad to hear that it worked out and that Copilot lived up to its billing!

When you get an opportunity for the follow-up, we would definitely love to hear about how you overcame the error, so as to help other users who might experience the same issue down the road.

Thanks!

@tbiel - I would be interested in how you solved this issue. I am going to start using this with my classes in a couple of weeks.