I am trying to use the CodePrint option


#1

I am trying to use the CodePrint option…when I past my code into the box and prepare to print, it doesn’t give me an option to save as PDF, only to literally print the document. Am I missing something?


#2

That is correct. On the PC, you can click on change to select a printer and there you should see the option to save as pdf. On the mac, the print dialog box has an option to save as pdf on the bottom left corner.


#3

hmm…I will try again. I didn’t see the PDF print option come up when I did that. I will try again and let you know how it goes. Thank you.


#4

Ahhhh…I got it! :slight_smile: It worked. thank you so much @bhatnagars



#5

Thank you for posting about this tool - I just shared it with my students and there were audible sighs of relief! This has cut down the time they thought they would need to devote to the PDF part. I somehow overlooked this link in the first stage of Unit 6.


#6

Yes, it’s great! We practiced using it and it is very user-friendly. Also using Screencast was very simple too!


#7

Make sure your students check the PDFs before submitting. I had one student where his circle and rectangle were pushed up five lines when he attempted to save as a PDF. He was using Chrome on Windows 10. I had no problems with Chrome on OSX. He redid it in Edge, and was able to create the pdf there with no problems. So… check - I’m sure it has something to do with browser print issues.


#8

Thanks for sharing this information!


#9

okay thank you! I will look out for this.


#10

Is there a way to create more then one oval with codePrint?


#11

It doesn’t look like it. I had students move all of their functions (main algorithm & two “mini” algorithms) that they were discussing in 2C together so they could put one oval around them.


#12

I feel like I’m going crazy. My class can’t get CodePrint to work today. We previewed this website two weeks ago, before we started the project, and it worked great. But now that students are at the point where they need to input their code, and actually use CodePrint it’s not functioning properly.

We can’t get the code to “prettify”. Nothing shows.

Can someone confirm that CodePrint is working for them?

Thank you!

UPDATE It started working again. For some reason it wasn’t working properly for about an hour this am. (3/27/17)


#13

I would also like to know if students can create more then one oval in CodePrint too!


#14

@damara.hartzell - I’m pretty sure you can only create 1 oval in the tool right now.

-Dani


#15

okay thank you @dani