Need Help with Unit 4 Lesson 17

My students and I are unable to import screens as described in CSD unit 4 lesson 17. I have tried everything I can think of and nothing seems to work. Talked with a CSP trainer about the problem and he was unable to help. Has anyone else experienced this problem? How can we fix it?

Hi @mwysock,

I’m sorry this is happening. Can you share a little more about what happens when they attempt an import? Is there an error message or is nothing at all happening?
My students worked in App Lab recently (about 2 weeks ago) and they were able to share screens. I am guessing you are familiar with the steps for importing screens but I’ll outline them here:

  1. User 1 and user 2 should make sure all elements are uniquely named.
  2. User 2 clicks share and copies the share link of their app and sends to user 1.
  3. User 1 goes to the screen dropdown and chooses “import” and pastes the share link from user 1 and imports the screen and assets (if all elements are uniquely named, there should not be conflicts).
  4. User 2 should also share any code they have via email or shared doc so that can be transferred.

After following these steps, if you are still having issues, you can contact support.

Good luck!
~Michelle

I am so glad someone posted this! I have a question about sharing their code. How does that work?

@heather.caster, Good question!

The code can be shared by switching to text mode and copying the text code (CTRL/CMD + C)

Then, as @melynn has noted, it can be emailed or pasted into a shared doc so the other student can copy it and paste it into their code window.

They can then switch back to block mode if they want and the code should be there in block format. They could also stay in text mode if they prefer.

Let us know if you run into any issues.

Mike

1 Like

Perfect! Unfortunately, my groups didn’t do so well at using unique IDs. This is my first time teaching the unit so I’ve learned from my mistakes and will readjust next trimester. :wink:

2 Likes